Connecting GNS3 on windows to remote hypervisoers
Page 1 of 1

Author:  minkimipt [ Wed Jun 18, 2014 7:00 pm ]
Post subject:  Connecting GNS3 on windows to remote hypervisoers

Hi all,

I've got a problem connecting my GNS3 to remote hypervisors. My local GNS3 is running on Windows machine and hypervisors are running on the Linux server. I have started hypervisors on the Linux machine:

linux-5psi:~/Cisco/tmp # pwd
linux-5psi:~/Cisco/tmp # ps -ef | grep -i dynami
root 1561 1461 0 22:33 pts/1 00:00:00 grep --color=auto -i dynami
root 31874 1 0 00:04 ? 00:04:32 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5000
root 31890 1 0 00:04 ? 00:04:26 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5001
root 31906 1 0 00:04 ? 00:04:32 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5002
root 31921 1 0 00:04 ? 00:04:31 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5003
root 31936 1 0 00:04 ? 00:04:25 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5004
root 31951 1 0 00:04 ? 00:04:26 ../dynamips-0.2.8-RC3-community-x86_64.bin -H 5005

I have setup port forwarding on the SSH session that I use to connect to the remote server with hypervisors. Port forwarding is working correctly sincee I can telnet to an the rest of the ports on my local machine.

I have setup hypervisors in GNS3 on my Windows machine as follows:

Port: 5000 TCP
Base UDP: 10001 UDP
Base console: 2000 TCP
Base AUX: 2501 TCP
Working directory: /root/Cisco/tcp

The rest of hypervisors are configured in the similar way.

Working directory exists on the remote server as you can see from the pwd output.

I have bound the default IOS image to the group of previously setup hypervisors. The actual IOS location is on Linux server rather then on the local machine: /root/Cisco/IOS/c7200-adventerprisek9-mz.152-4.S5.image
IOS is really in the directory on the server:

linux-5psi:~/Cisco/tmp # ls /root/Cisco/IOS/

And now we are close to my problem. When I am dragging the first router to the project I am getting the error in GNS3 console:

=> *** Warning: Could not set working directory to c:\users\d5357~1.zhi\appdata\local\temp\GNS3_hpckmj\working on server

For some reason it is still trying to set the working directory on the Linux machine to the path from windows machine. I have tried setting working directory in all possible places in GNS3 configuration. The only place where I can actually set the path in Linux style (with straight slash) is in hypervisor configuration mode. The rest of places where I tried to configure it reverted the slashes to windows backward style slashes and those settings didn't change anything. It is still trying to set the working directory to the wrong location.

Is there any way to force GNS3 to set the working directory to what is configured in hypervisor mode?

Author:  Paul808 [ Sat Aug 30, 2014 12:58 pm ]
Post subject:  Re: Connecting GNS3 on windows to remote hypervisoers

ya, same is with me. Having same problem :(

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group