It is currently Sun Oct 25, 2020 10:16 am


All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Qemu gets stuck when running ASA from GNS3
PostPosted: Thu Mar 11, 2010 9:55 pm 
Greetings. I'm using Ubuntu 9.10. I have succeeded in running ASA from a console following instruction from a "How to" (http://blog.gns3.net/2009/12/how-to-emulate-cisco-asa/). But I have a problem trying to initiate it from GNS3. It get STUCK when the device starts. The System monitor shows that qemu is doing something and CPU resources are being used. But when a do a "ps -A" it says that qemu's state is <<defunct>>. I have checked several posts in different blogs. I have tried to modify options in Qemu configuration tab inside GNS3. Nothing happend.

I wonder if any of you had faced this problem before and ware able to solve it.

I'm looking forward for you reply.

Thanks a lot in advance.




Attachments:
Qemu gets stuck when running ASA from GNS3.png
Qemu gets stuck when running ASA from GNS3.png [ 7 KiB | Viewed 6333 times ]
Top
  
 
 Post subject: Re: Qemu gets stuck when running ASA from GNS3
PostPosted: Fri Apr 02, 2010 10:19 pm 
I have the exact same issue on Ubuntu 9.10. I can't find information on how to resolve this issue. If you find out can you please send me a message with the answer to this problem?


Top
  
 
 Post subject: Re: Qemu gets stuck when running ASA from GNS3
PostPosted: Tue Apr 27, 2010 9:05 pm 
I am also having the same exact problem. Can someone please point me in the right direction to resolve this. Not finding a solution posted anywhere.
Thanks.


Top
  
 
 Post subject: Re: Qemu gets stuck when running ASA from GNS3
PostPosted: Tue Jun 01, 2010 7:54 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hello,

I installed a fresh install of Ubuntu 10.4. Then followed the howto (btw which is going to be modified soon ) to make my ASA kernel + initrd.

Then download GNS3 code source.

Installed the dependencies with sudo apt-get install python-qt4.

Started GNS3, went to Qemu preferences, pushed test button to see that everything was green.

Dropped an ASA device on the GNS3 workspace. Started it and then connected with a console. No issues.

So maybe you did a mistake when you extracted your ASA kernel + initrd. Also I used qemu-0.11.0

Hope this will help.

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Qemu gets stuck when running ASA from GNS3
PostPosted: Sat Sep 24, 2011 8:54 am 
I am seeing a similar problem. I am running ubuntu 10.04, GNS3 0.8.1,
and a patched version of qemu 0.11.0.

The routers come up fine.

When I run an ASA from gns3 "ps -f" shows the following. The
console spawned from gns3 using telnet connects but there is
no output even after hitting return.


/usr/local/bin/qemu -name ASA1 -m 256 -hda /opt/GNS3/tmp/ASA1/FLASH -kernel /opt/GNS3/ASA/asa802-k8.kernel -initrd /opt/GNS3/ASA/asa802-k8.initrd.gz -append console=ttyS0,9600n8 bigphysarea=16384 auto nousb ide1=noprobe hda=980,16,32 -net nic,vlan=0,macaddr=00:00:ab:7a:6b:00,model=e1000 -net nic,vlan=1,macaddr=00:00:ab:dc:fa:01,model=e1000 -net nic,vlan=2,macaddr=00:00:ab:7d:73:02,model=e1000 -net nic,vlan=3,macaddr=00:00:ab:0a:de:03,model=e1000 -net nic,vlan=4,macaddr=00:00:ab:5a:10:04,model=e1000 -net nic,vlan=5,macaddr=00:00:ab:c5:0b:05,model=e1000 -serial telnet:localhost:3000,server,nowait -hdachs 980,16,32



If I take exactly the same command, add quotes around the
"-append" parameters and run it from the command line the
ASA comes up fine and I can connect to it using "telnet
localhost 3000".

This points to some problem with the gns3 ASA/qemu code.




Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO