It is currently Sun Nov 17, 2019 9:13 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Running CCP on Parallels VM against GNS3 routers
PostPosted: Mon Feb 18, 2013 2:38 am 
Offline

Joined: Fri Dec 23, 2011 8:29 pm
Posts: 32
Hey all,

I'm currently studying for the CCNA-Security exam. I have a Parallels Win 7 VM running on my Mac that I wanted to use to run Cisco Configuration Professional against routers in GNS3 running on the same Mac. So I dragged out a "Host" icon and configured the Generic Ethernet NIO to be "vnic0" which was the vnic associated with the VM. This happily worked, and I can reach the routers from my Win 7 VM. But, after I start up CCP and discover a router, and then try to do any configuration on the router, CCP dies with an error message stating, "An internal error has occurred. Cisco CP will shutdown. Restart Cisco CP and discover the devices again." I did a Wireshark capture against the router interface that the VM was doing the http against, and I do see CCP making calls against the router and the router returning answers, like so:

Code:
(CCP PC)
POST /ios_web_exec/commandset HTTP/1.1
Content-Length: 117
Connection: Keep-Alive
Authorization: Basic d2Rlbm5pczoxcTJ3M2U=
User-Agent: Jakarta Commons-HttpClient/3.0
Host: 10.211.55.253

! COMMANDSET VERSION="1.0"
! OPTIONS BEGIN
! MODE="0"
! OPTIONS END
show environment
! END
! COMMANDSET END

(router)
HTTP/1.1 200 OK
Date: Fri, 01 Mar 2002 03:54:38 GMT
Server: cisco-IOS
Connection: close
Transfer-Encoding: chunked
Content-Type: text/plain
Expires: Fri, 01 Mar 2002 03:54:38 GMT
Last-Modified: Fri, 01 Mar 2002 03:54:38 GMT
Cache-Control: no-store, no-cache, must-revalidate
Accept-Ranges: none

000000F4

! COMMANDSET VERSION="1.0" STATUS="0"
! COMMAND_OUTPUT BEGIN
! COMMAND BEGIN
show environment
! COMMAND END
! OUTPUT BEGIN

Power Supply:

.Redundant Power System is  present.
.Thermal status:  normal
.Input Voltage status:  normal
000000A4

.DC Output Voltage status:  normal


Board Temperature:

.normal.


Fan status:

.normal.

! OUTPUT END
! STATUS BEGIN
PARSE_ERROR="0"
! STATUS END
00000016

! COMMAND_OUTPUT END
00000012

! COMMANDSET END
0


Anyone seen a problem like this before? I'm running CCP with Java 6u11, which is supposedly the supported Java version. Wonder if it's a problem with running CCP against a GNS3 router, or if it's just a general CCP/Java problem??




Top
 Profile  
 
 Post subject: Re: Running CCP on Parallels VM against GNS3 routers
PostPosted: Tue Feb 19, 2013 12:52 am 
Offline

Joined: Fri Dec 23, 2011 8:29 pm
Posts: 32
OK, fixed it... Read in CCP release notes that app must either be installed by PC administrator (which it wasn't, since at that point I didn't know it had to be) or if not, the app must be run under administrator context (right-click, choose "Run as Administrator".) Doing the second option (running as administrator) works. Happy that I can can do my CCNA-Sec studies all within the context of my laptop :)




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO