It is currently Tue Jul 14, 2020 9:32 am

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Olive finally fixed, I think....
PostPosted: Wed Jun 29, 2011 6:33 am 

Joined: Wed Jun 29, 2011 4:05 am
Posts: 19
I signed up to report that finally I've got qemu/olive working (fully) I think.

But I tell you it was many an hour (I won't admit how many) trying to get a crappy interface to show up. By the time the sun was rising I think I wanted to punch my stupid monitor in the face, cuss it out, and plead with the dumbo computer to make qemu/olive to just 'work'.

I started out with qemu from the debian repos (0.12.5) but was missing some kinda pxe...rom everytime I started qemu. I ignore this and figure the error can't be that important. So I telnet to the olive but am getting all this watchdog gibberish. I remember from inetpro's website to git seabios :) and patch! Not too hard. Moving right along. Am now able to get a junos cli prompt. But no interfaces. I took a guess that maybe I needed kvm. Installed that (also from debian repo). But then the junk that linux spits out at boot up said something about kvm module failed to start. In the end it would prove sheer luck that I just happened to notice this. I mean I could have been distracted by the hottie in the next cube. Well, hot, by IT standards. But as the butterfly flaps it's wings in Brazil, so it was I glanced at the screen with good timing.

Ok, then I'm digressing...problems still aren't solved. KVM isn't running, dmesg tells me so. What the hell could be wrong now? I just got this computer and can't something go right? That's when I remembered bios. Ok, flipped the Virtualization switch but still no interfaces in olive (well not usable ones). So I I went & git qemu after purging the deb installation. Compiled & still it didn't work. Removed & Reinstalled KVM. Now I have interfaces. I'm the baddest dude ever; 'I know Linux'. Haha that's nerdy, like a goober and untrue. I know linux to just shy of the thoroughness of whatever howto google can find. And that's a varied scale there! Yes I admit.

I digress again. So I'm pluggin' right along. Learning Juniper. Shit by the end of the week I think man 'I know Juniper!'. I'm billy bad ass. Think I'll mount a mirror on my monitor! Low and behold a pending ego crash is just right around the corner. It's time for part dos of the fasttrack study guides. Ah yes, routing. Routing and ip addressing and ping'in.

So here was the final problem.... Three routers daisy'chained. I start two and ping across. That's good. I start the third and ping from from the middle. No response. And from the third, I'm getting all kinds of funky (yes that is an official OSI troubleshooting term. Look it up, it's in the presentation layer). characters on screen. This jerk of a router is giving me the finger! Such a nice present. What the hell do I do now. I've spent so much time installing, reinstalling, compiling. I am missing patches of hair and I am no longer sure of which qemu is running. Not to mention all the hours spent reconditioning my typing from 'the other vendor's' (that's a dig on the fastrak study guides :) style. Ebay is about to see it's first ever "I will pay you to take this computer..that really doesn't have a pirated operating system, honestly!" post. Wipe'd, with nix only, & sans olive, of course.

It is then that I finally decide to just wipe the hard drive, install fresh and see if that will get things working. Maybe I just have to much 'debris' floating around. It's gonna take a while to install the o/s from scratch. But, oh well...I decide what the hell. Think I'll search for everything with *qemu* in it and delete. Then give the 'olive reloaded' howto a try.

That fixed it. Along with many of brezular's post. (Yes dude I just linked your posts. Kinda creepy but I found them informative). And to give credit I learned quite a bit from the various howto's floating out there on the net. The final combination: qemu 0.11.0, qemu patch per blog, qemu-kvm, and get this... seabios patched per inetpro but it's from one of my previous installations. Apparently an apt purge doesn't really purged everything.

Also thanks to everyone that had a problem and posted about it. If noone speaks, noone that must mean we don't want Noone to get smart(?).

p.s....If I run into some other problem I won't be able to post about it (yes I know you're breathing a sigh of relief) because a baseball bat will be working over my hard drive.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group