GNS3
http://forum.gns3.net/

ASA 8.42 firmware device segfaulting
http://forum.gns3.net/topic6505.html
Page 1 of 1

Author:  jmusbach [ Fri Jun 14, 2013 8:28 pm ]
Post subject:  ASA 8.42 firmware device segfaulting

Hello, so in my GNS3 topology I've utilized a ASA 8.42 virtual firewall device and in general the QEMU emulation and console functions work fine. However I have discovered that if it is left running for about half a day it'll eventually segfault endlessly (reboot loop) as shown below. Is this a bug with GNS3 or...?

http://pastebin.com/G8W8LyMK

Author:  grossmj [ Fri Jun 14, 2013 8:43 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

Imo, this is more a problem with Qemu. Don't think we can do much. Maybe you can try other version of Qemu and let us know if this change something.

Thanks,

Author:  jmusbach [ Fri Jun 14, 2013 8:49 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

Hm, maybe this is due to the patched nature of the GNS3 qemu binary?

Author:  grossmj [ Fri Jun 14, 2013 9:15 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

Don't think so, the patch essentially adds UDP tunnel support. The patch isn't necessary for Qemu versions >= 1.1

Author:  jmusbach [ Fri Jun 14, 2013 9:18 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

Oh, so this should work with any recent version of qemu then?

Author:  grossmj [ Fri Jun 14, 2013 9:40 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

Quote:
Oh, so this should work with any recent version of qemu then?


Yes and no. Depending of your platform, recent Qemu versions can be unstable when running ASA. What platform and Qemu version you used?

Author:  jmusbach [ Mon Jun 17, 2013 1:13 pm ]
Post subject:  Re: ASA 8.42 firmware device segfaulting

I'm running Mac OS X 10.8, I'm using QEMU 1.1 from your sourceforge repository.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/