GNS3
http://forum.gns3.net/

Error starting GNS3 1.0 Beta 1
http://forum.gns3.net/topic11388.html
Page 1 of 1

Author:  damico [ Fri Aug 01, 2014 1:10 am ]
Post subject:  Error starting GNS3 1.0 Beta 1

Hi,

I installed new GNS3 1.0 Beta1. After installation, I was getting an error saying that there is no gns3server. So I searched on internet, and installed the server. Now, after I start gns3, I'm getting the error on image.
Image

Please help me to fix this. Thanks.

Author:  claydon_dan [ Fri Aug 01, 2014 8:28 am ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

Hi,

You need to downgrade the version of Tornado that is installed - https://github.com/GNS3/gns3-server/issues/22

Author:  BlocNation99 [ Wed Aug 06, 2014 6:26 pm ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

How do you downgrade Python-Tornado?

Author:  claydon_dan [ Wed Aug 06, 2014 8:40 pm ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

BlocNation99 wrote:
How do you downgrade Python-Tornado?


First remove the newer tornado, then install the older version
Code:
pip uninstall tornado
pip install tornado=3.2.2

Author:  jyoaku002 [ Fri Aug 08, 2014 1:57 am ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

thanks for the pip command but it did not work on Ubuntu for me

hunted down sudo apt-get purge python3-tornado which removed (3.1.1-1ubuntu2) from my system

still getting the socket error but will keep looking for a solution
hopefully this isnt a NIC driver problembut that is thinking out loud until I retry a new load and possibly reinstall the GNS3 loads

Author:  damico [ Wed Aug 13, 2014 11:02 pm ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

claydon_dan wrote:
BlocNation99 wrote:
How do you downgrade Python-Tornado?


First remove the newer tornado, then install the older version
Code:
pip uninstall tornado
pip install tornado=3.2.2


I could remove, but couldn't install with "pip install tornado=3.2.2"

I got this error

Code:
/usr/local/bin/pip run on Wed Aug 13 20:00:19 2014
Exception:
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 257, in run
    InstallRequirement.from_line(name, None))
  File "/usr/local/lib/python2.7/dist-packages/pip/req.py", line 172, in from_line
    return cls(req, comes_from, url=url, prereleases=prereleases)
  File "/usr/local/lib/python2.7/dist-packages/pip/req.py", line 70, in __init__
    req = pkg_resources.Requirement.parse(req)
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources.py", line 2667, in parse
    reqs = list(parse_requirements(s))
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources.py", line 2605, in parse_requirements
    line, p, specs = scan_list(VERSION,LINE_END,line,p,(1,2),"version spec")
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources.py", line 2573, in scan_list
    raise ValueError("Expected "+item_name+" in",line,"at",line[p:])
ValueError: ('Expected version spec in', 'tornado=3.2.2', 'at', '=3.2.2')


I don't know if this will help, but when I start GNS3 from command line I got this:
Code:
~ $ gns3
GNS3 GUI version 1.0beta1
Copyright (c) 2007-2014 GNS3 Technologies Inc.
[I 140813 20:18:04 main:75] current locale is en_US.UTF-8
[I 140813 20:18:04 __init__:444] Dynamips module reset
[I 140813 20:18:04 __init__:413] IOU module reset
[I 140813 20:18:04 __init__:274] vpcs module reset
[I 140813 20:18:04 __init__:369] VirtualBox module reset
[I 140813 20:18:04 topology:256] topology has been reset
[I 140813 20:18:04 main_window:1175] creating temporary topology file: /tmp/gns3-8gdusply
[I 140813 20:18:04 main_window:1178] creating temporary project files directory: /tmp/gns3-8gdusply-files
[I 140813 20:18:04 __init__:175] local working directory for Dynamips module: /tmp/gns3-8gdusply-files
[I 140813 20:18:04 __init__:140] local working directory for IOU module: /tmp/gns3-8gdusply-files
[I 140813 20:18:04 __init__:82] local working directory for VPCS module: /tmp/gns3-8gdusply-files
[I 140813 20:18:04 __init__:154] local working directory for VirtualBox module: /tmp/gns3-8gdusply-files
[I 140813 20:18:06 servers:212] new local server connection ws://127.0.0.1:8000 registered
[I 140813 20:18:06 websocket_client:300] connection closed with server 127.0.0.1:8000
[E 140813 20:18:06 websocket_client:131] could to connect ws://127.0.0.1:8000: Invalid response status: b'403' b'Forbidden'


Author:  claydon_dan [ Thu Aug 14, 2014 9:47 am ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

Okay... That's my mistake... I was running in venv so pip called pip3.

Try running the same commands but substitute pip3 in place of pip

Alternatively... You can run the dev version from github where the main issue has been fixed now

Author:  damico [ Thu Aug 14, 2014 2:31 pm ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

claydon_dan wrote:
Okay... That's my mistake... I was running in venv so pip called pip3.

Try running the same commands but substitute pip3 in place of pip


Thanks for the answer. I tried this way, but didn't work.

Quote:
Alternatively... You can run the dev version from github where the main issue has been fixed now


I found the version 4.0.1 at github, installed, but the same error keep ocurring.

Author:  claydon_dan [ Thu Aug 14, 2014 2:51 pm ]
Post subject:  Re: Error starting GNS3 1.0 Beta 1

damico wrote:
I found the version 4.0.1 at github, installed, but the same error keep ocurring.


Apologies again... I meant the dev versions of gns3-server and gns3-gui (https://github.com/GNS3)

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/