GNS3
http://forum.gns3.net/

Multiple nio_gen_eth interfaces on cloud device!
http://forum.gns3.net/topic10694.html
Page 1 of 1

Author:  ak2766 [ Sat Jun 28, 2014 9:04 am ]
Post subject:  Multiple nio_gen_eth interfaces on cloud device!

Jeremy,

As per your request on GitHub, I'm in the middle of implementing a Fortigate appliance for a client and having never worked with the device before, I'm attempting to simulate its operation. Now, I've managed to get it all working, but it appears to cause a lot of clutter in my topology.

In the image below, each interface on the Fortigate VM requires its own cloud device. This works as expected barring the clutter!
Attachment:
File comment: Multiple cloud devices simulating an interface on the Fortigate appliance! For this instance, I'm only using 4 interfaces on the Fortigate to simulate 4 VLANs.
fortigate-experiment-multi-cloud.gns3- — GNS3_009.png
fortigate-experiment-multi-cloud.gns3- — GNS3_009.png [ 123.37 KiB | Viewed 3666 times ]


In the image below, it only works for the first link I attach to the cloud device. So, if I attach interface 1 to the IOU device first followed by the others, only traffic for VLAN1 will flow. If I attach interface 2 to the IOU device first followed by the others, only traffic for VLAN2 will flow and so on and so forth, yadi yada...
Attachment:
File comment: Single cloud device with 4 vmnet host-only interfaces configured that attach to 4 interfaces on the Fortigate appliance to simulate 4 VLANs.
fortigate-experiment-single-cloud.gns3- — GNS3_007.png
fortigate-experiment-single-cloud.gns3- — GNS3_007.png [ 127.58 KiB | Viewed 3666 times ]


My enhancement request was to enable a single cloud to be used thereby reducing clutter.

During my attempts to declutter my topology, I also tried adding a nio_gen_linux interface but the following error appeared on the console where I launched gns3:
Code:
[I 140628 19:01:32 base:213] ZeroMQ client (iou) sending JSON-RPC custom error: Requested NIO does not exist or is not supported: nio_linux_ethernet for call id b41cf442-c346-446f-b2e1-7981174ff761
[E 140628 19:01:32 iou_device:425] error while adding an UDP NIO for IOU1: Requested NIO does not exist or is not supported: nio_linux_ethernet


Cheers,
ak.

Edit: Here's the link on Github: https://github.com/GNS3/gns3-gui/issues/67

Author:  ak2766 [ Sat Jun 28, 2014 2:10 pm ]
Post subject:  Re: Multiple nio_gen_eth interfaces on cloud device!

And here is a shot of the Fortigate I'm tasked with configuring:
Attachment:
File comment: Fortigate 110C
fortigate-110c.png
fortigate-110c.png [ 100.88 KiB | Viewed 3649 times ]


The 4 VLANs I'm using on the device are connected to ports 1-4 respectively. In production, I'll be using all 8 ports on the device and 1 WAN port to daisy chain 2 of them together. My experiment on GNS3 is to help me get a feel for how configuration is performed on the Fortigate devices!


Cheers,
ak.

Author:  jasfree [ Sun Sep 28, 2014 3:25 pm ]
Post subject:  Re: Multiple nio_gen_eth interfaces on cloud device!

Hi ak,

did you ever get a solution for this?

I too am trying to find a solution so that I can replicate/troubleshoot various problems that we are encountering.

Author:  ak2766 [ Fri Oct 10, 2014 3:00 pm ]
Post subject:  Re: Multiple nio_gen_eth interfaces on cloud device!

Hi jasfree.

I actually did not have an issue using the first setup (barring the clutter) and was able to get a greater understanding of the Fortigate and was able to finish off my configuration for my client.

It is an interesting device to work with - especially being that you can use the VLANs in a non-traditional manner - grouping machines together in a VLAN, but still having all VLANs in the same subnet and able to communicate with each other - no routing needed! It took a while to get that through my mind!

If you have issues, please post the specifics and I'll see if I can assist!

Cheers,
ak.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/