It is currently Mon Aug 19, 2019 10:57 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: BUG - Permissions (1.0b1.dev.1)
PostPosted: Fri Jul 18, 2014 2:37 am 
Offline

Joined: Tue Jul 17, 2012 1:34 pm
Posts: 214
Multi-platform - 1.0b1.dev1

Hey Jeremy,

Here's another issue that I think needs to be addressed. Using both OS X and Linux, I can no longer connect to a Cloud node interface (TAP or NIO Ethernet) after I assign root permissions to dynamips using chown and chmod. When attempting to connect a device to the cloud node, the GNS3 console produces the error, "dynamips has no privileges to access /dev/tap0." This effectively cripples the usefulness of the Cloud node.

On Linux I can use setcap to resolve this, but in OS X there's no setcap command. I've tried a few things, like using chmod on /dev/tap0 specifically, but I've had no good results. It appears not to be a permissions issue with dynamips or the dev files, but rather some other issue, perhaps within the new gns3server.



_________________
J.Neumann, GNS3 Contributor & Forum Moderator (Minion ID: sin.zx81.1981ad)
Author: Cisco Routers for Small Business (Apress)


Top
 Profile  
 
 Post subject: Re: BUG - Permissions (1.0b1.dev.1)
PostPosted: Fri Jul 18, 2014 2:49 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hey Jason,

I have removed the checks in the server. This should be ok now.



_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO