GNS3
http://forum.gns3.net/

Exception/traceback error
http://forum.gns3.net/topic11316.html
Page 1 of 1

Author:  AyrishGrl [ Sun Jul 27, 2014 11:35 pm ]
Post subject:  Exception/traceback error

Not sure if this is the place to report this or not.

I have only just setup GNS3-ER using VB and IOU today. I am running v1.0 beta 1. All I have done so far is setup 4 IOU switches, 6 routers and a GNS3 switch to connect routers to IOU switch. I have not booted any devices up yet, just ran connections from each router to the switch and the inter-switch connections on the IOU devices. I save topology and when I opened it up after closing it I get traceback and exception detected.

=== GNS3 1.0beta1 traceback on 27 Jul 2014 19:27:48 ===
Traceback (most recent call last):
File "./gns3-gui\gns3\main_window.py", line 359, in _openRecentFileSlot
File "./gns3-gui\gns3\main_window.py", line 1136, in loadProject
File "./gns3-gui\gns3\topology.py", line 477, in load
File "./gns3-gui\gns3\modules\dynamips\nodes\ethernet_switch.py", line 450, in load
File "./gns3-gui\gns3\modules\dynamips\nodes\ethernet_switch.py", line 83, in setup
KeyError: 'type'
=== GNS3 1.0beta1 traceback on 27 Jul 2014 19:29:51 ===
Traceback (most recent call last):
File "./gns3-gui\gns3\main_window.py", line 359, in _openRecentFileSlot
File "./gns3-gui\gns3\main_window.py", line 1136, in loadProject
File "./gns3-gui\gns3\topology.py", line 477, in load
File "./gns3-gui\gns3\modules\dynamips\nodes\ethernet_switch.py", line 450, in load
File "./gns3-gui\gns3\modules\dynamips\nodes\ethernet_switch.py", line 83, in setup
KeyError: 'type'

Not sure what steps to take.

Author:  gt57 [ Thu Jul 31, 2014 1:00 am ]
Post subject:  Re: Exception/traceback error

I have the exact same error after closing and reopening a project with two routers and two switches. After reopening, the switches did not appear.

O/S: Windows 8.1 x64

GNS3 server version 1.0beta1
Copyright (c) 2007-2014 GNS3 Technologies Inc.
Running with Python 3.3.5 and has PID 9312
[W 140730 20:50:21 __init__:79] vboxwrapper couldn't be found!
[I 140730 20:50:21 server:223] ZeroMQ server listening to 127.0.0.1:51722
Starting server on 127.0.0.1:8000 (Tornado v3.2, PyZMQ v14.2.0, ZMQ v4.0.4)
[I 140730 20:50:21 jsonrpc_websocket:118] Websocket client 9ac436df-8471-4bf6-8117-eab821961413 connected
[I 140730 20:50:21 web:1728] 200 GET /version (127.0.0.1) 1.00ms

[EDIT]
Just read this note topic11132.html which seems to acknowledge the error. I did delete some of the default Ethernet switch ports.

Author:  grossmj [ Wed Aug 13, 2014 8:38 pm ]
Post subject:  Re: Exception/traceback error

This has been fixed now. Please see topic11132.html

Thanks,

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/