GNS3
http://forum.gns3.net/

[SOLVED] VMnet # > 9 cannot connect - Windows GNS3 1.0 beta2
http://forum.gns3.net/topic12062.html
Page 1 of 1

Author:  gt57 [ Wed Sep 17, 2014 6:09 pm ]
Post subject:  [SOLVED] VMnet # > 9 cannot connect - Windows GNS3 1.0 beta2

I am unable to connect a Cloud device that has one or more VMnet interfaces numbered greater than 9. GNS3 console error:

Server error [-3200] from 127.0.0.1:8000 SW1: unable to create generic ethernet NIO

I can see all the VMnet interfaces from Powershell:
PS C:\Windows\System32\WindowsPowerShell\v1.0> gwmi Win32_NetworkAdapter | ? name -like '*vmware*' | select Name

Name
----
VMware Virtual Ethernet Adapter for VMnet1
VMware Virtual Ethernet Adapter for VMnet8
VMware Virtual Ethernet Adapter for VMnet9
VMware Virtual Ethernet Adapter for VMnet0
VMware Virtual Ethernet Adapter for VMnet2
VMware Virtual Ethernet Adapter for VMnet3
VMware Virtual Ethernet Adapter for VMnet4
VMware Virtual Ethernet Adapter for VMnet5
VMware Virtual Ethernet Adapter for VMnet6
VMware Virtual Ethernet Adapter for VMnet7
VMware Virtual Ethernet Adapter for VMnet10
VMware Virtual Ethernet Adapter for VMnet11
VMware Virtual Ethernet Adapter for VMnet12
VMware Virtual Ethernet Adapter for VMnet13
VMware Virtual Ethernet Adapter for VMnet14

The .gns3 file list the adapter above 10:


{
"name": "unsaved",
"resources_type": "local",
"topology": {
"links": [
{
"description": "Link from Cloud 1 port nio_gen_eth:VMware Network Adapter VMnet10 to SW1 port 1",
"destination_node_id": 1,
"destination_port_id": 1,
"id": 1,
"source_node_id": 2,
"source_port_id": 9
},


[snip]
{
"description": "Cloud",
"id": 2,
"label": {
"color": "#000000",
"font": "Consolas,10,-1,5,75,0,0,0,0,0",
"text": "Cloud 1",
"x": 54.0151515151515,
"y": 21.73484848484849
},
"ports": [
{
"id": 9,
"name": "nio_gen_eth:VMware Network Adapter VMnet10",
"stub": true
},
{
"description": "connected to SW1 on port 1",
"id": 11,
"link_id": 2,
"name": "nio_gen_eth:VMware Network Adapter VMnet9",
"nio": "NIO_Generic_Ethernet",
"stub": true
}
],
"properties": {
"name": "Cloud 1",
"nios": [
"nio_gen_eth:VMware Network Adapter VMnet10",
"nio_gen_eth:VMware Network Adapter VMnet9"
]
},


I just noticed the config for VMnet10 is missing " "nio": "NIO_Generic_Ethernet", "

Author:  gt57 [ Sun Sep 28, 2014 3:20 am ]
Post subject:  Re: [SOLVED] VMnet # > 9 cannot connect - Windows GNS3 1.0 b

Beta 3 allows VMnets above 9 on Windows.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/