GNS3
http://forum.gns3.net/

[SOLVED] connect gns3 router to iou device
http://forum.gns3.net/topic8976-10.html
Page 2 of 2

Author:  claydon_dan [ Sat May 17, 2014 10:15 am ]
Post subject:  Re: [SOLVED] connect gns3 router to iou device

hsingh wrote:
Seriously, that's the site admin's response to me?

How about something useful, like: update your host binding under Server Preferences to use the correct adapter's IP address (192.168.56.1) ??

Please remember, Jeremy (grossmj) is not only the site admin, but main developer for GNS3 so is incredibly busy.

The way Jeremy answered the question was to help you learn. Simply giving you the answer doesn't teach you anything.

By finding out what is special about 127.0.0.1 helps you to become more knowledgeable.

Author:  hsingh [ Sat May 17, 2014 10:50 am ]
Post subject:  Re: [SOLVED] connect gns3 router to iou device

Hey Dan,

Not sure why I didn't take it that way. Maybe it was because on Apr 2 grossmj said "This is a current and intentional limitation. It will be fixed in alpha2." so my post was really about whether the functionality made it into Alph 4. I didn't think it warranted a reply telling me to learn "basic networking".

Anyways, sorry for any grief, misunderstandings do happen..

GNS3 is awesome and I can't wait to dive deeper into it and I know there's some great folks here in this forum on the same path...

Author:  grossmj [ Sat May 17, 2014 9:23 pm ]
Post subject:  Re: [SOLVED] connect gns3 router to iou device

There was a limitation in alpha1 to connect IOS to IOU but this has been fixed in alpha2. However, this still up to the user to configure the local server host binding, I haven't found a reliable way to automatically configure this setting.

Author:  ofmanyone [ Wed Oct 22, 2014 5:37 pm ]
Post subject:  Re: [SOLVED] connect gns3 router to iou device

Just installed GNS3 1.0 full (not beta). I got the L2 IOU Image running, but I'm still getting that same error. I understand that 192.168.56.101 is the GNS3 VirtualBox VM, but I don't understand why my loopback address 127.0.0.1 is trying to connect to it when I try to attach an IOS router to the IOU L2 VM. Can someone please explain what setting is wrong and how to change it? I'm a senior network engineer, but a novice at linux/unix and all but basic GNS3 architecture. Thanks for your help guys.

Author:  ofmanyone [ Wed Oct 22, 2014 5:51 pm ]
Post subject:  Re: [SOLVED] connect gns3 router to iou device

I found it! I hope that this is helpful to some of you. Edit\Preferences\GNS3 server\Host binding. The default is "127.0.0.1" which is the standard loopback ip address that GNS3 typically uses to connect to the various virtual devices running within it. However, this doesn't work with a GNS3 VM IOU Server. Change the "Host binding" setting to "192.168.56.1", which should be there if you installed the GNS3 IOU VM in VirtualBox.

BTW, regarding the message that you'll typically get when trying to launch IOU "...wwwin-gnged.cisco.com...", that URL is only available internally to Cisco personnel. If you're lucky enough to know someone who works for Cisco, then you might get it to work. If not, good luck to you.

I successfully connected a 2691 router to a L2 IOU image and it's working perfectly! I've been wanting to do this for years, and it's finally here! Thanks guys!

Page 2 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/