GNS3
http://forum.gns3.net/

how to fix this: libcrypto.so.4: wrong ELF class: ELFCLASS64
http://forum.gns3.net/topic9392.html
Page 1 of 1

Author:  conan1993ai [ Fri Apr 18, 2014 5:00 pm ]
Post subject:  how to fix this: libcrypto.so.4: wrong ELF class: ELFCLASS64

The gns3 tell me :

=> Server notification: node IOU1: IOU has stopped running
/home/conan/桌面/gns3/i86bi_linuxl2-ipbasek9-ms-15.1B.bin: error while loading shared libraries: libcrypto.so.4: wrong ELF class: ELFCLASS64

I'm using the ubuntu 14.04 lts x64,and trying to install alpha2, who can help me?!!!!Thank you very much!

I have tried this:
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0
sudo apt-get install libssl1.0.0:i386
sudo apt-get install libtinfo5:i386
sudo rm /usr/lib/libcrypto.so.4
sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.4

but it does't work,the problem still exists.

Author:  revs [ Fri Apr 18, 2014 5:31 pm ]
Post subject:  Re: how to fix this: libcrypto.so.4: wrong ELF class: ELFCLA

conan1993ai wrote:
sudo rm /usr/lib/libcrypto.so.4
sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.4

but it does't work,the problem still exists.


I am not sure why you are trying to remove /usr/lib/libcrypto.so.4 (is it even there? what distro are you using?), but the link should be pointing to a 32-bit libcrypto, and you are trying to link it to a 64-bit version of the library.

Author:  conan1993ai [ Sat Apr 19, 2014 11:09 am ]
Post subject:  Re: how to fix this: libcrypto.so.4: wrong ELF class: ELFCLA

revs wrote:
conan1993ai wrote:
sudo rm /usr/lib/libcrypto.so.4
sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.4

but it does't work,the problem still exists.


I am not sure why you are trying to remove /usr/lib/libcrypto.so.4 (is it even there? what distro are you using?), but the link should be pointing to a 32-bit libcrypto, and you are trying to link it to a 64-bit version of the library.


thank you very much!I've solved them!

Author:  fpippo [ Wed Aug 06, 2014 3:50 pm ]
Post subject:  Re: how to fix this: libcrypto.so.4: wrong ELF class: ELFCLA

Hi , can You explain how to solve?

Thanks

FP

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/