It is currently Sat Sep 21, 2019 1:25 pm


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: [SOLVED] Missing context menu icons for non-root user
PostPosted: Sat May 03, 2014 11:50 am 
Offline

Joined: Fri May 04, 2012 11:37 am
Posts: 57
Location: Point Cook, Australia
I've seen this issue since alpha 1 but haven't had the time to report.

When I run the gui as a normal user, the context menu has no icons - see images below:
- normal-user.png
- root-user.png

Cheers,
ak.

Edit: This on Ubuntu 14.04...

Edit2: Went back to GNS3 0.8.6 briefly and noticed that problem exists there as well. I've always run GNS3 as root-user so never thought anything of it until I tried running the new GNS3 as normal user and stumbled onto this problem. I found out a long time ago when I started using GNS3 that running as root user causes the least amount of problems so have always run it with sudo.




Attachments:
File comment: When running GNS3 GUI as root user, context menu has icons...
root-user.png
root-user.png [ 120 KiB | Viewed 2213 times ]
File comment: When running GNS3 GUI as normal user, context menu has no icons...
normal-user.png
normal-user.png [ 123.17 KiB | Viewed 2213 times ]
Top
 Profile  
 
 Post subject: Re: Missing context menu icons for non-root user - alpha3
PostPosted: Sat May 03, 2014 10:36 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
This is a system wide/GTK problem. I don't know why but menu icons are deactivated by default (at least on Ubuntu).

http://www.howtogeek.com/howto/21149/ho ... nnoyances/

Use the following commands to activate them:

Code:
gconftool-2 --type boolean --set /desktop/gnome/interface/buttons_have_icons true
gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons true

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: [SOLVED] Missing context menu icons for non-root user
PostPosted: Sun May 04, 2014 1:34 am 
Offline

Joined: Fri May 04, 2012 11:37 am
Posts: 57
Location: Point Cook, Australia
Thanks Jeremy.

That's bloody irritating; why have a GUI based OS if the menu icons are not enabled by default! It appears that Ubuntu developers have lost the plot in my opionion. Why would they enable icons for some menu items and not others??? Tsk, tsk, tsk... I would never have figured that one out on me own, so big thanks!

On my system (default Ubuntu 14.04 install) I had the following defaults:
Code:
$ gconftool-2 --get /desktop/gnome/interface/buttons_have_icons
false
$ gconftool-2 --get /desktop/gnome/menus_have_icons
No value set for `/desktop/gnome/menus_have_icons'


Cheers,
ak.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO