Error saving projects on with remote hypervisor
Page 1 of 1

Author:  AC439 [ Mon Feb 09, 2009 7:33 pm ]
Post subject:  Error saving projects on with remote hypervisor

Hi...I have installed GNS3 on 2 winXP PCs and there is no problems running labs and the PCs are talking to each other. However, when I try to save the projects, I get the following error:-

Traceback (most recent call last):

File "GNS3\ProjectDialog.pyo", line 85, in accept

File "GNS3\Workspace.pyo", line 686, in createProject

LookupError: unknown encoding: %s: %s

It ONLY happens when there is an instance of router emulation running on a remote hypervisor. I did google and yahoo trying to research for answer but found no reference. I have no idea what the "LookupError: unknown encoding: %s: %s" is referring to. It seems to me this is an error from Python. I guess it is telling me the remote hypervisor is having problems saving a the .cfg file or creating a project directory.

Anyone shed some lights on it please?
Thanks - AC

Author:  kaage [ Tue Feb 10, 2009 2:40 pm ]
Post subject:  Re: Error saving projects on with remote hypervisor

It's not possible to use projects with remote hypervisor. Check this:

Author:  AC439 [ Tue Feb 10, 2009 10:18 pm ]
Post subject:  Re: Error saving projects on with remote hypervisor

Thanks. This just confirms my thoughts that this part is not working within GNS3.

I have tried out other options such as using export /all or save /all. Basically, save /all is broken. I have read somewhere else that it is not working and the only working solution (so far as I have figured out but quite clumsy) is to use export /all with the .net file saved first. Then when I reopen the project, I will load the .net file that import /all back the router cfg files. Then you have to separate the .net and .cfg files between project and put them into different folders. Also, the working directory can cause problems if you use same router names on different projects.

I'm debating myself if I should go pure dynamips (since things has to be done manually with distribute servers) or just go with one powerful multi-core PC and stay with GNS3.

- AC

Author:  AC439 [ Thu Feb 12, 2009 3:12 am ]
Post subject:  Re: Error saving projects on with remote hypervisor

This is just a follow-up on my own debate of the subject.

The reason I started to investigate the distributed hypervisor setup was the CPU usage on my Dell 170L P3.2GHz 2GB was getting to around 96-98% with a 8-routers lab (IDLEPC has been properly adjusted). I then tried the same lab on my AMD athalon 64x2 3800+ PC (also 2GB) and the overall CPU usage was only about 15-25%.

Therefore, I concluded that, first, my Dell PC was definitely not a fast one (even with a 3.2G Pentium CPU and 2GB). Second, it seems to me GNS runs better with everything on the same PC (i.e. no distributed hypervisor). It saves .net and .cfg automatically and put them in separate directories. So, the verdict is to get a fast CPU (dual core or even better with quad) and save the hassle of running on multiple PCs.

I have also tried Ubuntu 8.10 and I dual boot the same Dell PC with XP. I did the same 4 routers lab on both O/S but XP's CPU usage was about 15-20% while the same lab on Ubuntu ran at 75%. The issue with Ubuntu was I cannot find a good IDLEPC after hours of trying and changing. On XP, once the IDLEPC is applied, CPU drops to almost zero. But on Ubuntu, CPU doesn't go below 25%. For some strange reasons, I'm getting opposite result from most Dynamips users on Ubuntu.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group