It is currently Sat Sep 21, 2019 7:44 pm


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Remotely Connect to ASA issues
PostPosted: Thu Dec 12, 2013 7:19 pm 
Offline

Joined: Tue Jan 24, 2012 1:58 am
Posts: 15
I'm receiving the error "the remote system refused the connection" when I attempt to putty from a machine on my network to an ASA running on GNS3 0.8.6 on my Ubuntu 12.10 host. When I'm logged in directly to the Ubuntu machine, I can access the ASA just fine. I've tried from other Ubuntu laptops on my network, Win 7 machines and even an XP laptop, all to no avail. I'm not sure if this is an Ubuntu configuration issue or a GNS3 issue. I've verified that when attempting to connect from a Win 7 and XP machine that my firewall was disabled, to no avail. I've also tried using putty, secure crt, telnet and various ssh clients.

I have basic connectivity to the Ubuntu machine and I'm using VNC to connect to the Ubuntu box and run my labs. If I use a topology that consists of all routers, I can connect remotely to the routers from another PC by using putty, connecting to the Ubuntu host and using the specific port for the router (e.g. 2101, 2102, etc...). When I try the same thing for an ASA, putty port 3001, it doesn't work. I've verified on the Ubuntu host that it is listening on port 3001 when I have the ASA powered on. I'm at a lost. Any assistance is greatly appreciated.

V/r
-Peanut




Top
 Profile  
 
 Post subject: Re: Remotely Connect to ASA issues
PostPosted: Sat Dec 14, 2013 11:42 pm 
Offline

Joined: Thu Jul 26, 2012 11:19 pm
Posts: 143
Location: U.K.
On your Linux box - netstat -na - What ip address is listening on port 3001?

_________________
GNS3 0.8.4 running on Windows 8.1
GNS3 0.8.4 running on CentOS 6.5


Top
 Profile  
 
 Post subject: Re: Remotely Connect to ASA issues
PostPosted: Sun Dec 15, 2013 4:45 pm 
Offline

Joined: Tue Jan 24, 2012 1:58 am
Posts: 15
It's showing as localhost:3001 for the ASA.

-Peanut


Top
 Profile  
 
 Post subject: Re: Remotely Connect to ASA issues
PostPosted: Mon Dec 16, 2013 9:36 am 
Offline

Joined: Thu Jul 26, 2012 11:19 pm
Posts: 143
Location: U.K.
Check your Qemu settings. It needs to be listening on an external interface rather than 127.0.0.1.

Preferences -> Qemu -> General Settings -> [/] Show Qemu wrapper advanced options -> drop down menu select ip of external interface.

You may also have to edit topology.net or create a new topology after you have changed it.
HTH.



_________________
GNS3 0.8.4 running on Windows 8.1
GNS3 0.8.4 running on CentOS 6.5


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO