GNS3
http://forum.gns3.net/

Qemu version 0.14.1 patched sources are not 'patched'
http://forum.gns3.net/topic8898.html
Page 1 of 1

Author:  strange [ Sun Mar 30, 2014 10:48 pm ]
Post subject:  Qemu version 0.14.1 patched sources are not 'patched'

First let me say that GNS3 is a very good tool. I've been able to build a complete (lacking firewalls) Corporate structure including a Data Center, Campus VLANs (both of those on seperate Layer 2 clouds) VPN routers with remotes and "part" of the Internet. All on a 6gig laptop. I'm using OpenNMS and have that reverse proxied through Apache and presented to the REAL Internet.

I post here in the hopes that someone else having these issues may find this in a search.

I've been struggling for over 2 weeks trying to get an ASA up. Due to my choice of Linux distro I've had to compile/install just about everything GNS3 related from sources. So I used those listed in the 'Downloads' section at http://www.gns3.net. I've seen numerous posts telling me to ignore the 'old AND unpatched' version message. But I realized that everything I do have working does not use Qemu at all.

In troubleshooting, I noticed that as long as I didn't connect any network connections to the firewall, it would come up and I could console to it. But connect even a single interface to it and it would start in GNS3 (go green) but console connections were refused.

After much verifying that Qemu was compiled correctly I started searching the web and came across the suggestion to troubleshoot by starting qemuwrapper.py manually and then starting GNS3 which would result in:

qemu: -net udp,vlan=0,sport=40000,dport=10001,daddr=127.0.0.1: Parameter 'type' expects a network client type

And the process would end.

Searching the code I could find no references to an interface of type udp. On a lark, I downloaded the patches and there "found" the missing code. After applying those and recompiling the error and the issue went away.

The long and short of it is, the link to the Patched Source points to unpatched code. Adding the 'Patches for Qemu 0.14.1 to support UDP tunnels' resolves the issue.

Regards,

strange

Author:  300cpilot [ Sat May 31, 2014 3:32 pm ]
Post subject:  Re: Qemu version 0.14.1 patched sources are not 'patched'

I have the same type of issue with a Centos 6.5 install, can't start an asa for nothing. The only error I can see is in Preferences when I hit test, it states Failed to start qemu. Where did you get the updated qemu from?

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/